use strict;
my $str = 'this
is
my
string';
my $regex = qr/.*/p;
my $subst = 'REPLACEMENT';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";