// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*").unwrap();
let string = "this
is
my
string";
let substitution = "REPLACEMENT";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}