using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[^\/]*?b.*?<\/.*?>|(b)";
string input = @"this is a nice day for bowling <b>bbbb</b> b <b> b </b>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}