re = /<[^\/]*?b.*?<\/.*?>|(b)/
str = 'this is a nice day for bowling <b>bbbb</b> b <b> b </b>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end