$re = '/<[^\/]*?b.*?<\/.*?>|(b)/';
$str = 'this is a nice day for bowling <b>bbbb</b> b <b> b </b>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);