import re
regex = re.compile(r"RIJDEN\?\s*(.+?)(?:\R+\d|\R*$)", flags=re.UNICODE | re.IGNORECASE)
test_str = ("testtestest\n\n"
"1. QUESTION QUESTION RIJDEN?\n"
"Txt pour regex1 \n"
" \n"
"2. QUESTION QUESTION BESTUURDER Txt p0ur regex2,\n\n"
" \n"
"3. QUESTION QUESTION /POSTCODE)\n"
"Txt pour regex3;rz\n"
" \n"
"Fin")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")