package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w+(?:#\d+)*(?:\.\w+(?:#\d+)*)*$`)
var str = `document.
document.role.
.document
docum#ent.role.id
document.role.#id
docu#1ment.role.id
document.ro#0#1le.id
document.role.id
document.role.id.and.other.very.long.path.example
document.role#0.id
document#1.role#0.id
document#1.role#0#1.id
document#1.role#0#1.id#21`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}