const regex = /^\w+(?:#\d+)*(?:\.\w+(?:#\d+)*)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w+(?:#\\d+)*(?:\\.\\w+(?:#\\d+)*)*$', 'gm')
const str = `document.
document.role.
.document
docum#ent.role.id
document.role.#id
docu#1ment.role.id
document.ro#0#1le.id
document.role.id
document.role.id.and.other.very.long.path.example
document.role#0.id
document#1.role#0.id
document#1.role#0#1.id
document#1.role#0#1.id#21`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}