use strict;
my $str = 'document.
document.role.
.document
docum#ent.role.id
document.role.#id
docu#1ment.role.id
document.ro#0#1le.id
document.role.id
document.role.id.and.other.very.long.path.example
document.role#0.id
document#1.role#0.id
document#1.role#0#1.id
document#1.role#0#1.id#21';
my $regex = qr/^\w+(?:#\d+)*(?:\.\w+(?:#\d+)*)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}