$re = '/^0x[a-fA-F0-9]{40}$/';
$str = '0xeB7C917821796eb627C0719A23a139ce51226CD2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);