import re
regex = re.compile(r"^0x[a-fA-F0-9]{40}$")
test_str = "0xeB7C917821796eb627C0719A23a139ce51226CD2"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")