#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[A-Z]{4} \d{3}(?:(?![A-Z]{4}).){4,40} \(\d\)"
Local $sString = "BMGT 310.ACCT 220 Principles of Accounting I (3)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")