$re = '/[A-Z]{4} \d{3}(?:(?![A-Z]{4}).){4,40} \(\d\)/';
$str = 'BMGT 310.ACCT 220 Principles of Accounting I (3)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);