import re
regex = re.compile(r"[A-Z]{4} \d{3}(?:(?![A-Z]{4}).){4,40} \(\d\)")
test_str = "BMGT 310.ACCT 220 Principles of Accounting I (3)"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")