# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(Technology libraries)(:\s+)(.*)//gm;t' <<< " Technology libraries: Techlibhellohellohello
Technology libraries: Techlibhellohellohello"