package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^ https:\/\/ |([a-z0-9\.]*\.)aexp.com$`)
var str = `https://hnjm.aexp.com
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}