$re = '/^ https:\/\/ |([a-z0-9\.]*\.)aexp.com$/i';
$str = 'https://hnjm.aexp.com
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);