const regex = /^ https:\/\/ |([a-z0-9\.]*\.)aexp.com$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ https:\\\/\\\/ |([a-z0-9\\.]*\\.)aexp.com$', 'i')
const str = `https://hnjm.aexp.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}