using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(<span>(?:(?1)|<(?!\/span>)|[^<]*+)*+<\/span>))";
string input = @"<span>string1 <span>string2</span><span> string3 <span>string4</span> <span>string5</span> </span> string11</span>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}