const regex = /(?=(<span>(?:(?1)|<(?!\/span>)|[^<]*+)*+<\/span>))/iug;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(<span>(?:(?1)|<(?!\\\/span>)|[^<]*+)*+<\\\/span>))', 'iug')
const str = `<span>string1 <span>string2</span><span> string3 <span>string4</span> <span>string5</span> </span> string11</span>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}