re = /(?=(<span>(?:(?1)|<(?!\/span>)|[^<]*+)*+<\/span>))/i
str = '<span>string1 <span>string2</span><span> string3 <span>string4</span> <span>string5</span> </span> string11</span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end