# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:.*\/|\G)\K(\S+)\s+/$1_/gm;t' <<< "foo bar abc def/Test Input File"