$re = '~(?:.*/|\G)\K(\S+)\s+~m';
$str = 'foo bar abc def/Test Input File';
$subst = "$1_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;