using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:.*/|\G)\K(\S+)\s+";
string substitution = @"$1_";
string input = @"foo bar abc def/Test Input File";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}