const regex = /\+CSPTGF: (?<groups>\d{1,3},\n(?:\d{1,3},[^,\n]{1,16},?\n)*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\+CSPTGF: (?<groups>\\d{1,3},\\n(?:\\d{1,3},[^,\\n]{1,16},?\\n)*)', 'g')
const str = `+CSPTGF: 202,
1,ALT PIRA SVA,
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}