import re
regex = re.compile(r"\+CSPTGF: (?<groups>\d{1,3},\n(?:\d{1,3},[^,\n]{1,16},?\n)*)")
test_str = ("+CSPTGF: 202,\n"
"1,ALT PIRA SVA,\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")