$re = '/\+CSPTGF: (?<groups>\d{1,3},\n(?:\d{1,3},[^,\n]{1,16},?\n)*)/';
$str = '+CSPTGF: 202,
1,ALT PIRA SVA,
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);