import re
regex = re.compile(r"\b[\w-]+(?:\.[\w-]+){2,}\b", flags=re.MULTILINE)
test_str = ("Received: by with SMTP id gx4so163592215ieb.1\n"
" for mail-ie0-x247.google.com <myemailaddress@gmail.com>; Mon, 01 Jun mail-ie0-x247.google.com 2015 18:34:50 -0700 (PDT)\n\n"
"max.google.com\n"
"Received: from localhost (localhost.localdomain [127.0.0.1])\n"
"by mail.server.com (Postfix) with ESMTP id 822B1190A4AF\n"
"for <alex@example.com>; Tue, 17 Feb 2015 13:13:54 +0000 (UTC)\n\n\n"
"Received: from [x.x.x.x] by mail.kampl.com (Cipher TLSv1.2:AES-SHA:128) (MDaemon PRO v15.0.1)\n\n"
"b-app05-06.boldchat.com\n"
"ns126a.ba1.enops.net\n"
"ms-out.evernote.com \n"
"obeml1.aerlingus.com\n"
"NHQSDFEXCHUB01.nam.coair.com\n"
"ncsmcexchub01.nam.coair.com\n"
"o1.em.thetaoofbadass.com\n\n"
"b-app05-06.boldchat.com\n"
"ns126a.ba1.enops.net\n"
"NHQSDFEXCHUB01.nam.coair.com\n"
"ncsmcexchub01.nam.coair.com\n\n"
"mta2l1.trans.r.grouponmail.co.uk\n"
"---...---.--.--.---.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")