import Foundation
let pattern = #"\b[\w-]+(?:\.[\w-]+){2,}\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Received: by with SMTP id gx4so163592215ieb.1
for mail-ie0-x247.google.com <myemailaddress@gmail.com>; Mon, 01 Jun mail-ie0-x247.google.com 2015 18:34:50 -0700 (PDT)
max.google.com
Received: from localhost (localhost.localdomain [127.0.0.1])
by mail.server.com (Postfix) with ESMTP id 822B1190A4AF
for <alex@example.com>; Tue, 17 Feb 2015 13:13:54 +0000 (UTC)
Received: from [x.x.x.x] by mail.kampl.com (Cipher TLSv1.2:AES-SHA:128) (MDaemon PRO v15.0.1)
b-app05-06.boldchat.com
ns126a.ba1.enops.net
ms-out.evernote.com
obeml1.aerlingus.com
NHQSDFEXCHUB01.nam.coair.com
ncsmcexchub01.nam.coair.com
o1.em.thetaoofbadass.com
b-app05-06.boldchat.com
ns126a.ba1.enops.net
NHQSDFEXCHUB01.nam.coair.com
ncsmcexchub01.nam.coair.com
mta2l1.trans.r.grouponmail.co.uk
---...---.--.--.---.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)