re = /\b[\w-]+(?:\.[\w-]+){2,}\b/m
str = 'Received: by with SMTP id gx4so163592215ieb.1
for mail-ie0-x247.google.com <myemailaddress@gmail.com>; Mon, 01 Jun mail-ie0-x247.google.com 2015 18:34:50 -0700 (PDT)
max.google.com
Received: from localhost (localhost.localdomain [127.0.0.1])
by mail.server.com (Postfix) with ESMTP id 822B1190A4AF
for <alex@example.com>; Tue, 17 Feb 2015 13:13:54 +0000 (UTC)
Received: from [x.x.x.x] by mail.kampl.com (Cipher TLSv1.2:AES-SHA:128) (MDaemon PRO v15.0.1)
b-app05-06.boldchat.com
ns126a.ba1.enops.net
ms-out.evernote.com
obeml1.aerlingus.com
NHQSDFEXCHUB01.nam.coair.com
ncsmcexchub01.nam.coair.com
o1.em.thetaoofbadass.com
b-app05-06.boldchat.com
ns126a.ba1.enops.net
NHQSDFEXCHUB01.nam.coair.com
ncsmcexchub01.nam.coair.com
mta2l1.trans.r.grouponmail.co.uk
---...---.--.--.---.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end