import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\p{Lu}[ \\p{L}]*):\\h*(.+?)(?:\\h-\\h(.+))?$";
final String string = "Asia: Asian Cup - Play Offs\n"
+ "Asia: Asian Cup\n"
+ "Asia: World Cup - Qualification - First Stage\n"
+ "Australia: A-League\n"
+ "Belgium: Jupiler League - Championship Group\n"
+ "Brazil: Série A\n"
+ "Some Word: Another Word - Extra Word";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}