$re = '/^(\p{Lu}[ \p{L}]*):\h*(.+?)(?:\h-\h(.+))?$/mu';
$str = 'Asia: Asian Cup - Play Offs
Asia: Asian Cup
Asia: World Cup - Qualification - First Stage
Australia: A-League
Belgium: Jupiler League - Championship Group
Brazil: Série A
Some Word: Another Word - Extra Word';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);