re = /^(\p{Lu}[ \p{L}]*):\h*(.+?)(?:\h-\h(.+))?$/m
str = 'Asia: Asian Cup - Play Offs
Asia: Asian Cup
Asia: World Cup - Qualification - First Stage
Australia: A-League
Belgium: Jupiler League - Championship Group
Brazil: Série A
Some Word: Another Word - Extra Word'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end