#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(25[0-5]|2[0-4][0-9]|1[0-9][0-9]|0?[1-9][0-9]?|0?[0-9]?[1-9])(.(25[0-5]|2[0-4][0-9]|[0-1]?[0-9]?[0-9])){2}.(25[0-5]|2[0-4][0-9]|1[0-9][0-9]|0?[1-9][0-9]?|0?[0-9]?[1-9])$"
Local $sString = "256.256.256.256" & @CRLF & _
"256.255.255.255" & @CRLF & _
"255.256.255.255" & @CRLF & _
"255.255.256.255" & @CRLF & _
"255.255.255.256" & @CRLF & _
"255.255.255.255" & @CRLF & _
"255.255.255.0" & @CRLF & _
"1.1.1.1" & @CRLF & _
"0.1.1.1" & @CRLF & _
"1.0.1.1" & @CRLF & _
"1.1.0.1" & @CRLF & _
"1.0.0.1" & @CRLF & _
"1.0.0.0" & @CRLF & _
"0.0.0.0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")