using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(25[0-5]|2[0-4][0-9]|1[0-9][0-9]|0?[1-9][0-9]?|0?[0-9]?[1-9])(.(25[0-5]|2[0-4][0-9]|[0-1]?[0-9]?[0-9])){2}.(25[0-5]|2[0-4][0-9]|1[0-9][0-9]|0?[1-9][0-9]?|0?[0-9]?[1-9])$";
string input = @"256.256.256.256
256.255.255.255
255.256.255.255
255.255.256.255
255.255.255.256
255.255.255.255
255.255.255.0
1.1.1.1
0.1.1.1
1.0.1.1
1.1.0.1
1.0.0.1
1.0.0.0
0.0.0.0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}