import re
regex = re.compile(r"^(25[0-5]|2[0-4][0-9]|1[0-9][0-9]|0?[1-9][0-9]?|0?[0-9]?[1-9])(.(25[0-5]|2[0-4][0-9]|[0-1]?[0-9]?[0-9])){2}.(25[0-5]|2[0-4][0-9]|1[0-9][0-9]|0?[1-9][0-9]?|0?[0-9]?[1-9])$", flags=re.MULTILINE)
test_str = ("256.256.256.256\n"
"256.255.255.255\n"
"255.256.255.255\n"
"255.255.256.255\n"
"255.255.255.256\n"
"255.255.255.255\n"
"255.255.255.0\n"
"1.1.1.1\n"
"0.1.1.1\n"
"1.0.1.1\n"
"1.1.0.1\n"
"1.0.0.1\n"
"1.0.0.0\n"
"0.0.0.0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")