package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:\d+(?:\.\d+)?)\/(?:\d+(?:\.\d+)?))|((?:[+-]?\d+(?:\.\d+)?)?[+-]?(?:\d+(?:\.\d+)?)?i)|([+-]?\d+(?:\.\d+)?)`)
var str = `-1 2/5 -0.4 1+3i -i 3i +2i -2i +3 -1+i -1-i +59i`
var substitution = "\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}