import Foundation
let pattern = #"((?:\d+(?:\.\d+)?)\/(?:\d+(?:\.\d+)?))|((?:[+-]?\d+(?:\.\d+)?)?[+-]?(?:\d+(?:\.\d+)?)?i)|([+-]?\d+(?:\.\d+)?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"-1 2/5 -0.4 1+3i -i 3i +2i -2i +3 -1+i -1-i +59i"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)