using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\)""(.+?)(?<!\\)""";
string input = @"""<p class=\""qwerty\"">Hello World</p>"" attribute2 = ""value2""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}