$re = '/(?<!\\\\)"(.+?)(?<!\\\\)"/';
$str = '"<p class=\\"qwerty\\">Hello World</p>" attribute2 = "value2"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);