re = /(?<!\\)"(.+?)(?<!\\)"/
str = '"<p class=\\"qwerty\\">Hello World</p>" attribute2 = "value2"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end