using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d+\K([A-Z]+)\d*(R(?:OA)?D|AVE(?:NUE)?|ST(?:REET)?|LANE|LN|BOULEVARD|BLVD)\b";
string input = @"77BIGBEAR45ROAD
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}