$re = '/\b\d+\K([A-Z]+)\d*(R(?:OA)?D|AVE(?:NUE)?|ST(?:REET)?|LANE|LN|BOULEVARD|BLVD)\b/';
$str = '77BIGBEAR45ROAD
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);