import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d+\\K([A-Z]+)\\d*(R(?:OA)?D|AVE(?:NUE)?|ST(?:REET)?|LANE|LN|BOULEVARD|BLVD)\\b";
final String string = "77BIGBEAR45ROAD\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}