#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([\n^].*)(?=[\n^]\S+:|$)"
Local $sString = "ixl1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500" & @CRLF & _
" options=e507bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,VLAN_HWFILTER,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6>" & @CRLF & _
" ether f8:f2:1e:51:d8:fb" & @CRLF & _
" inet 100.0.0.196 netmask 0xff000000 broadcast 100.255.255.255" & @CRLF & _
" inet6 1234::196 prefixlen 64" & @CRLF & _
" inet6 fe80::faf2:1eff:fe51:d8fb%ixl1 prefixlen 64 scopeid 0x5" & @CRLF & _
" media: Ethernet autoselect (10Gbase-Twinax <full-duplex>)" & @CRLF & _
" status: active" & @CRLF & _
" nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")