$re = '/([\n^].*)(?=[\n^]\S+:|$)/';
$str = 'ixl1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=e507bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,VLAN_HWFILTER,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6>
ether f8:f2:1e:51:d8:fb
inet 100.0.0.196 netmask 0xff000000 broadcast 100.255.255.255
inet6 1234::196 prefixlen 64
inet6 fe80::faf2:1eff:fe51:d8fb%ixl1 prefixlen 64 scopeid 0x5
media: Ethernet autoselect (10Gbase-Twinax <full-duplex>)
status: active
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);