# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([\n^].*)(?=[\n^]\S+:|$)"
test_str = ("ixl1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500\n"
" options=e507bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,VLAN_HWFILTER,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6>\n"
" ether f8:f2:1e:51:d8:fb\n"
" inet 100.0.0.196 netmask 0xff000000 broadcast 100.255.255.255\n"
" inet6 1234::196 prefixlen 64\n"
" inet6 fe80::faf2:1eff:fe51:d8fb%ixl1 prefixlen 64 scopeid 0x5\n"
" media: Ethernet autoselect (10Gbase-Twinax <full-duplex>)\n"
" status: active\n"
" nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.