use strict;
my $str = 'Abc0Z
+++++';
my $regex = qr/^[^0-9A-Z]+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";