$re = '/^[^0-9A-Z]+$/m';
$str = 'Abc0Z
+++++';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;