#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?P<quotes>"|''')" & @CRLF & _
"(?P<names1>.*?)" & @CRLF & _
"\b[Vv]\b" & @CRLF & _
"(?P<names2>.*?)" & @CRLF & _
"\s*\[?" & @CRLF & _
"\s*\b(?P<day>[1-9]|[12]\d|3[01])\b" & @CRLF & _
"\s*\b(?P<month>(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)\w*)\b" & @CRLF & _
"\s*\b(?P<year>\d{4})\b" & @CRLF & _
"\s*\]?" & @CRLF & _
"\1" & @CRLF & _
""
Local $sString = "1 "R J BRUCE & OTHERS V B J & W L A EDWARDS And Ors CA CA19/02 27 February 2003"," & @CRLF & _
"2 "H v DIRECTOR OF PROCEEDINGS [2014] NZHC 1031 [16 May 2014]"," & @CRLF & _
"3 '''GREGORY LANCASTER AND JOHN HENRY HUNTER V CULLEN INVESTMENTS LIMITED AND ERIC JOHN WATSON CA CA51/03 26 May 2003'''" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")